This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.

X-E3 build quality issues, is it normal?

Discussion in 'X-E1, X-E2, X-E2S and X-E3' started by jacobd, Oct 24, 2017.

  1. jacobd

    jacobd Member

    Joined:
    Jun 26, 2015
    Messages:
    11
    Likes Received:
    8
    Location:
    Denmark

    -Return to Top-

    I did return the first X-E3 and bought another one after trying out different samples in a shop. This one has less of a wobbly screen - and comparable to other X-E3s - and a fully fixed thumb-grip. This one I am keeping. The 23mm f2 I have no experience with so I cannot help you there.
     
  2. mango

    mango Member

    Joined:
    Jun 21, 2011
    Messages:
    18
    Likes Received:
    19
    Location:
    Bangkok

    -Return to Top-

    Just post my update : I did go to Fujifilm service center in Bangkok today to have my 16mm f1.4 checked for inaccurate aperture setting and I shown them the loose thumb rest on my X-E3 that maybe I will need to send it to fix after my use on next week. They just asked to check for it and had my camera to service team, after ten minutes wait they return the camera, everything fixed, back to perfect condition.
     
    rayvonn likes this.
  3. jptsr1

    jptsr1 Active Member

    Joined:
    Nov 8, 2017
    Messages:
    62
    Likes Received:
    35
    Location:
    New Jersey

    -Return to Top-

    I have the same. probably wouldn't have noticed if I wasn't looking for it though.
     
  4. jimgallaher

    jimgallaher Member

    Joined:
    Apr 11, 2015
    Messages:
    24
    Likes Received:
    7
    Location:
    Northern Ireland

    -Return to Top-

    Got my X-E3 yesterday. No issues with mine, screen is fine and thumbgrip is rock solid.
     
    rayvonn likes this.
  5. jjesp

    jjesp New Member

    Joined:
    Jun 28, 2017
    Messages:
    4
    Likes Received:
    0

    -Return to Top-

    Regarding the thumb grip. I have heard that the problem is two loose screws inside the camera on the backside. If the grip is loose, you have to disassembly the camera and tighten these screws. So if you can't live with it, send it to Fuji for a tightening, under warranty . It should take less than 10 minutes (but the problem with Fuji, is that they don't have a service center in every country. So it can take some weeks before you have your camera back :( )
     

Share This Page